We have been running Exchange 2007 basically since it was released.  Over all it is a great product and quite an upgrade over Exchange 2003.  Last month SP1 was released with some much anticipated improvements, including major improvements in the administrative UI, OWA, and more.  Unfortunately not all of us gets those new features.

The service pack installer is actually a full copy of exchange, not an patch. So just like the first time you install Exchange 2007 the setup runs through the "Readiness Check" to make sure you meet all the requirements.  Seeing how Exchange is already installed I wasn't too concerned about not meeting any of the requirements.  Boy was I wrong.  I was quickly greeted with an unexpected error message:

Error:

Microsoft Exchange Server 2007 setup cannot continue because this computer belongs to a domain that has a single-labeled DNS name. DNS domain name: mydomainname

Humm.  That's not good.  It appears that exchange doesn't like the fact that the windows domain name is "mydomainname" instead of something like "mydomainname.local" or "mydomainname.com".   I knew this day would come.  We have avoided renaming the domain for a while now because it is not a fun process.  The instructions to rename a domain are contained in an 82 page 1.2MB word document, and that's before you event get into the exchange stuff.

So I read all the documentation and was prepared to pull the trigger when I came across an interesting Knowledge Base article.  In summary you can't rename a domain that has an Exchange 2007 server in it, and if you do the only solution is to rename it back.

So I can't install SP1 with a single labeled DNS name and if you have Exchange 2007 already installed you can't rename the domain.  Microsoft just backed me into a corner.

I'm not alone as it appears there are several other people with this problem.  The worst part is the lack of documentation.  None of the release notes talk about this the requirement.  Even the new Deployment checklist doesn't say anything about it.

HELP MICROSOFT!!!  We want SP1 too.

UPDATE: 
It looks like the Exchange team is listening.  They posted on their blog that they are looking into the problem and will have an update by February 15th.  If you don't want to wait commenter inf pointed me to a registry hack to get around the domain check.
Posted at 12/20/2007 7:52 PM
Comments [4] - Permalink
Monday, 04 February 2008 08:46:41 (Eastern Standard Time, UTC-05:00)
I did come across a help site with a work-around: www.outlook-web-access.com - first item. It does say its not supported, but if your looking to do some testing before re-doing your active directory domain it might be worth a shot

cheers.
inf
Monday, 04 February 2008 16:11:49 (Eastern Standard Time, UTC-05:00)
Thanks for the link, looks promising. I'll update the post
Monday, 02 February 2009 08:53:38 (Eastern Standard Time, UTC-05:00)
Slightly unrelated, but I've recently started using Exclaimer to manage our exchange email disclaimers - so far I have been really impressed with this tool - I highly recommend it.
Saturday, 06 August 2011 06:54:53 (Eastern Daylight Time, UTC-04:00)
thankx alot
My name
OpenID
Please login with either your OpenID above, or your details below.
Name
E-mail
Home page

Comment (Some html is allowed: a@href@title, i) where the @ means "attribute." For example, you can use <a href="" title=""> or <blockquote cite="Scott">.  

Enter the code shown (prevents robots):

Live Comment Preview